Skip to main content
← All vulnerabilities
CVE-2026-84890GHSA-3XPG-4RPP-HHHM

undici vulnerable to Denial of Service via unbounded decompression of compressed responses

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.29.1, 8.10.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output size is unbounded and there is no configuration option to limit it. A malicious or faulty upstream can therefore return a small compressed payload, a compression bomb, that expands to hundreds of megabytes or more in client memory, an asymmetric resource consumption that can exhaust memory and crash the process. This affects undici versions from 7.15.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • undici undici

    From 7.15.0 · fixed in 7.29.1; From 8.0.0 · fixed in 8.10.2

  • undicinpm

    From 7.15.0 · fixed in 7.29.1

  • undicinpm

    From 8.0.0 · fixed in 8.10.2

References 2

GitHub · nodejs/undici

cna.openjsf.org