jackson-databind omits java.lang.Comparable from DefaultBaseTypeLimitingValidator's unsafe base types
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.18.10, 2.21.6, 2.22.2, 3.1.6, 3.2.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: poc
- Automatable: no
- Technical impact: partial
Summary
DefaultBaseTypeLimitingValidator is the PolymorphicTypeValidator applied automatically whenever @JsonTypeInfo is used without an explicitly configured custom validator. It denies polymorphic resolution only for a fixed set of "unsafe base types", and its isSafeSubType method returns true unconditionally for every base type outside that set. java.lang.Comparable was absent from the list despite being implemented by a very large fraction of JDK and application classes, comparable in breadth to java.io.Serializable, which is on the list for that reason. An application declaring an @JsonTypeInfo-annotated property or class with Comparable as its base type, and no custom PolymorphicTypeValidator, will accept a type identifier for essentially any class implementing Comparable. This yields an attacker-controlled object instantiation primitive; a demonstrated case constructs a java.io.File for an arbitrary attacker-chosen path, which becomes path-traversal-adjacent if the application subsequently calls path-sensitive methods on the value. No class implementing Comparable has been identified that yields code execution through deserialization alone. Global Default Typing via activateDefaultTyping is not affected, because that method structurally requires an explicit PolymorphicTypeValidator argument. This affects com.fasterxml.jackson.core:jackson-databind from 2.11.0 before 2.18.10, from 2.19.0 before 2.21.6, and from 2.22.0 before 2.22.2, and tools.jackson.core:jackson-databind from 3.0.0 before 3.1.6 and from 3.2.0 before 3.2.2. Users should upgrade to 2.18.10, 2.21.6, 2.22.2, 3.1.6, or 3.2.2.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: poc · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- com.fasterxml.jackson.core:jackson-databind
From 2.11.0 · fixed in 2.18.10; From 2.19.0 · fixed in 2.21.6; From 2.22.0 · fixed in 2.22.2
- tools.jackson.core:jackson-databind
From 3.0.0 · fixed in 3.1.6; From 3.2.0 · fixed in 3.2.2
- tools.jackson.core:jackson-databindMaven
From 3.0.0 · fixed in 3.1.6
- tools.jackson.core:jackson-databindMaven
From 3.2.0 · fixed in 3.2.2
- com.fasterxml.jackson.core:jackson-databindMaven
From 2.11.0 · fixed in 2.18.10
- com.fasterxml.jackson.core:jackson-databindMaven
From 2.19.0 · fixed in 2.21.6
- com.fasterxml.jackson.core:jackson-databindMaven
From 2.22.0 · fixed in 2.22.2