Skip to main content
← All vulnerabilities
CVE-2026-8327GHSA-WMW3-3FV3-H54W

Concrete CMS below 9.5.0 and below is vulnerable to password change without reauthorization and session-hardening bypass.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.5.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Concrete CMS below 9.5.0 and below is vulnerable to password change without reauthorization and session-hardening bypass. The user-profile edit controller passes the entire raw POST array to UserInfo::update() without field whitelisting resulting in password change without requiring the current password  and also resulting in registered users able to disable the per-user-IP-pinning in the session validator which is meant to detect hijacking.  The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 5.3 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N. Thanks 0x4c616e for reporting.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Concrete CMS Concrete CMS

    From 5 · through 9.5.0

  • concrete5/concrete5Packagist

    fixed in 9.5.1

References 1

documentation.concretecms.org